Aiutamici Forum
Benvenuto Ospite Cerca | Topic Attivi | Utenti | | Log In | Registra

Difficoltà di visualizzazione sito in IE e non in FF Opzioni
speedy63
Inviato: Thursday, November 17, 2011 7:50:51 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
Ciao è da moltissimo tempo che ho problemi di visualizzazione del mio sito in IE mentre in FF è tutto a posto, il problema riscontrato in IE è per quanto riguarda il menù di sinistra e precisamente alla voce Indice Xp accanto al triangolino dovrebbe spuntare l'elenco accanto con le voci errori, faq, e così via uno sotto l'altro ma non funziona, sono in trattativa con Lui49 per riuscire a visualizzare bene il mio sito, ringrazio per lo sforzo che mi sta dedicando.
il mio sito è speedy63

grazie!!!!
Sponsor
Inviato: Thursday, November 17, 2011 7:50:51 PM

 
a.roselli
Inviato: Thursday, November 17, 2011 8:57:01 PM

Rank: Admin

Iscritto dal : 10/4/2000
Posts: 18,825
Alcuni script menu per pagine web non sono compatibili con tutti i browser, bisogna trovare un menu compatibile.



Alfonso Roselli - alfonso_aiutamici@hotmail.it
lui49
Inviato: Thursday, November 17, 2011 9:17:48 PM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
come dice Alfonso, non tutti i browser supportano i medesimi script e <tag> in specie con questi tipi di menù. Ti ho mandato la soluzione che puoi modificare a piacere. Anzi te la rimando aggiornata:

newmenu.zip
speedy63
Inviato: Friday, November 18, 2011 7:04:36 AM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
Lui49 scusami ma non riesco a farlo come lo hai fatto mi esxce come indice puntato ti mando un esempio



Uploaded with ImageShack.us il menù di sinistra mi viene spostato.

questo è il punto dove ho inserito il css

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<title>home</title>
#cm-nav li a.arrow {background-image: url('arrow-right.gif')}
ul#cm-nav, ul#cm-nav ul {
border-bottom: 0.5px solid red;
list-style-type: none;
margin: 0px;
list-style-image: url('none');
border-right: 0.5px solid red;
padding: 0px
}
la posizione è giusta?

l'immagine del quadratino la devo inserire insieme con il file tramite ftp?

Riandate a questa pagina modificata home1.htm alternativa del mio sito

Nella cartella file newmenu.zip mi trovo un immagine arrow-right ho riportato lo stesso nella mia cartella images uplodata tramite ftp e mi spunta il menu ad elenco puntato, mi si visualizza il quadratino ma il problema non cambia, anzi inserendo il file css ed eseguendo home1.htm mi trovo il codice scritto sopra la pagina stessa
lui49
Inviato: Friday, November 18, 2011 11:31:58 AM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
No, non è giusto. O lasci il css esterno come ho fatto io o, se lo vuoi incorporare nel documento devi inserirlo sì fra <head> e </head> ma racchiuso tra i tags <style type="text/css"> e </style>

l'immagine freccia è gestita dal css; se questo non è a posto non la vedi di certo.

Il css è sempre meglio lasciarlo esterno perchè qualsiasi modifica allo stesso si ripercuote su tutte le pagine che lo richiamano, altrimenti dovresti correggerle tutte una ad una.
speedy63
Inviato: Friday, November 18, 2011 11:39:08 AM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
il ccs esterno devo metterlo nella home cartella sito? per funzionare?
lui49
Inviato: Friday, November 18, 2011 11:43:26 AM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
puoi metterlo dove vuoi: meglio se assieme a tutti i tuoi .htm; se lo metti altrove devi specificare, negli .htm (per dirla terra a terra) il percorso per rintracciarlo.

se lo metti assieme (puoi anche rinominarlo come vuoi) quindi ti basta, in ogni .htm, inserire:
Code:
<head>
<link href="cm-style.css" rel="stylesheet" type="text/css">
</head>
speedy63
Inviato: Friday, November 18, 2011 12:14:33 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
lui49 ho messo il codice nella sezione dedicata ed è apparso l'elenco come lo hai fatto ma ancora la freccia a destra non appare.

questo è quello che si vede in IE home1.htm

questo è quello che si vede in FF home1.htm

lui49
Inviato: Friday, November 18, 2011 12:21:57 PM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
sostituisci tutto il menù da <ul> dopo

<ul id="cm-nav" class="arrow-pad">
<ul>
fino a </ul> prima di </div>

col menù che ho fatto io. Non puoi lasciare richiami ad un css che non esite più. (fai copia-incolla)


Code:
    <ul>
    <li><a href="#">Home</a>
        <li><a href="#nogo" class="arrow">Indice XP </a>
            <ul>
            <li><a href="#nogo">Errori</a></li>
            <li><a href="#nogo">Faq</a></li>
            <li><a href="#nogo">Servizi</a></li>
            <li><a href="#nogo">Sicurezza</a></li>
            <li><a href="#nogo">Trucchi</a></li>
            <li><a href="#nogo">Utlility</a></li>
            <li><a href="#nogo">Videoguide</a></li>
            <li><a href="#nogo">Manuali</a></li>
            </ul>
        </li>
        <li><a href="#nogo" class="arrow">Vista</a>
            <ul>
            <li><a href="#nogo">Errori</a></li>
            <li><a href="#nogo">Faq</a></li>
            <li><a href="#nogo">Servizi</a></li>
            <li><a href="#nogo">Sicurezza</a></li>
            <li><a href="#nogo">Trucchi</a></li>
            <li><a href="#nogo">Utlility</a></li>
            <li><a href="#nogo">Videoguide</a></li>
            <li><a href="#nogo">Manuali</a></li>
            </ul>
        </li>
        <li><a href="#nogo" class="arrow">Sette</a>
        <ul>
            <li><a href="#nogo">Errori</a></li>
            <li><a href="#nogo">Faq</a></li>
            <li><a href="#nogo">Servizi</a></li>
            <li><a href="#nogo">Sicurezza</a></li>
            <li><a href="#nogo">Trucchi</a></li>
            <li><a href="#nogo">Utlility</a></li>
            <li><a href="#nogo">Videoguide</a></li>
            <li><a href="#nogo">Manuali</a></li>
        </ul>
        </li>
        <li><a href="#nogo">Windows8</a></li>
        <li><a href="#nogo" class="arrow">Linux</a>
        <ul>
            <li><a href="#nogo">Errori</a></li>
            <li><a href="#nogo">Faq</a></li>
            <li><a href="#nogo">Servizi</a></li>
            <li><a href="#nogo">Sicurezza</a></li>
            <li><a href="#nogo">Trucchi</a></li>
            <li><a href="#nogo">Utlility</a></li>
            <li><a href="#nogo">Videoguide</a></li>
            <li><a href="#nogo">Manuali</a></li>
        </ul>
        </li>
        <li><a href="#nogo" class="arrow">Somac</a>
        <ul>
            <li><a href="#nogo">Errori</a></li>
            <li><a href="#nogo">Faq</a></li>
            <li><a href="#nogo">Servizi</a></li>
            <li><a href="#nogo">Sicurezza</a></li>
            <li><a href="#nogo">Trucchi</a></li>
            <li><a href="#nogo">Utlility</a></li>
        </ul>
        </li>
                <li><a href="#nogo">Documenti1</a></li>
                <li><a href="#nogo">eMail</a></li>
                <li><a href="#nogo">Browser</a></li>
                <li><a href="#nogo">Software</a></li>
                <li><a href="#nogo">Hardware</a></li>
                <li><a href="#nogo">Grafica</a></li>
                <li><a href="#nogo">Adsl</a></li>
                <li><a href="#nogo">Wi-Fi</a></li>
                <li><a href="#nogo">Html</a></li>
                <li><a href="#nogo">GuestBook</a></li>
                <li><a href="#nogo">Sommario</a></li>
    </ul>



e modifica in questa riga:

<td style="vertical-align: top; width: 130px;" height="411"> il valore 130 in 103

anche in questa:

<td style="vertical-align: top; width: 130px;" height="71"><img src="images/f7928736.jpg" alt="" style="width: 102px; height: 68px;"></td>
speedy63
Inviato: Friday, November 18, 2011 4:45:43 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
al posto del #nogo devo mettere indicexp.htm e del arrow devo mettere arrow-write? perchè ancora non funziona bene il triangolino verso destra non appare nè in FF nè in IE
lui49
Inviato: Friday, November 18, 2011 5:41:06 PM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
al posto dei #nologo devi mettere i link delle pagine da aprire. Hai caricato il file "arrow-right.gif" assieme al css?

La pagina del sito non è a posto (non hai fatto opia-incolla del codice)......sei fanatico dei <br>?


Se vuoi risolvere alla svelta rinomina la tua pagina Home e sostituiscila con la mia......
speedy63
Inviato: Friday, November 18, 2011 6:22:50 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
al posto dei nogo ho messo le pagine da aprire, il file css lo messo separato non assieme all'immagine

il copia incolla lo fatto, per quanto riguarda i br quelli si aggiungono ogni volta che faccio modifiche in automatico non sono un fanatico lo faccio con kompozer lo devo con il blocco note?
lui49
Inviato: Friday, November 18, 2011 6:35:18 PM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
lui49 ha scritto:
...Hai caricato il file "arrow-right.gif" assieme al css?



intendo: l'hai caricato nel medesimo spazio dove hai messo il css?

Non uso Kompozer, preferisco editor testuali tipo questo (che in pratica è proprio un blocco-note) e non lo conosco bene ma mi sembra strano questo comportamento.
Non hai fatto copia-incolla perchè hai aggiunto, anche dove non è necessaria, la chiamata alla class="arrow" (che è quella che provoca la visione della freccetta).

Segui il consiglio dell'ultima riga del mio precedene....
speedy63
Inviato: Friday, November 18, 2011 7:30:11 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
la chiamata alla class arrow lo messa solo alle voci indicexp, vista, etc.. lo tolte dalle altre voci che non servivano tipo errori ed altro, ho copiato e incollato il menù che mi hai dato ma continua a darmi l'elenco puntato

qui è il punto dove ho inserito il css

<html>
<head>
<title>home</title>
<link href="cm-style.css" rel="stylesheet" type="text/css">
</head>

qui è il punto dove ho inserito il menù mandato da te

<ul id="cm-nav" class="arrow-pad">
<ul>
<li><a href="home.htm">Home</a> </li>
<li><a href="indicexp.htm" class="arrow">Indice XP </a>
<ul>

qui ho corretto la larghezza

<td style="vertical-align: top; width: 103px;" height="411">
<div style="display: table; width: 103px;">

<tr>


Questa è la situazione del menù

<li><a href="vista.htm" class="arrow">Vista</a>
<ul>
<li><a href="errori1.htm">Errori1</a></li>
<li><a href="faq1.htm">Faq1</a></li>
<li><a href="servizi1.htm">Servizi1</a></li>
<li><a href="sicurezza1.htm">Sicurezza1</a></li>
<li><a href="trucchi1.htm">Trucchi1</a></li>
<li><a href="utility1.htm">Utility1</a></li>
<li><a href="videoguide1.htm">Videoguide1</a></li>
<li><a href="manuali1.htm">Manuali1</a></li>
</ul>


<td style="vertical-align: top; width: 103px;" height="71"><img
src="images/f7928736.jpg" alt="" style="width: 102px; height: 68px;"></td>

ho fatto tutto quello che mi hai accennato ma non è cambiato niente sempre elenco puntato se mi sfugge qualcosa dimmi pure!!!

lui49
Inviato: Friday, November 18, 2011 8:28:14 PM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
Cancella tutti i <br> che trovi nella sezione menù.....


Oppure: prendi i tre files che ti ho inviato (menu1.html, cm-style.css, arrow-right.gif) e mettili nella cartella assieme a tutti gli altri files .htm che hai. Rinomina il tuo file "home.htm" in quello che vuoi, poi rinomina il file "menu1.html" in "home.htm". Fatto... Drool
speedy63
Inviato: Friday, November 18, 2011 8:43:27 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
come vedi non ci sono br se vedi tutte le voci distanziate l'uno dall'altro lo dà Kompozer, nella sezione sorgente è così come lo vedi, perchè mi devi fare cambiare il file menu1.html quando precedentemente c'è home.htm come pagina iniziale così significa andare a ricorregere tutte le pagine del sito perchè in ogni pagina devo andare a correggere la pagina home.htm
lui49
Inviato: Friday, November 18, 2011 9:00:20 PM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
speedy63 ha scritto:
come vedi non ci sono br se vedi tutte le voci distanziate l'uno dall'altro lo dà Kompozer, nella sezione sorgente è così come lo vedi, perchè mi devi fare cambiare il file menu1.html quando precedentemente c'è home.htm come pagina iniziale così significa andare a ricorregere tutte le pagine del sito perchè in ogni pagina devo andare a correggere la pagina home.htm



questo è poco ma sicuro....se modifichi il menù devi fare altrettanto in tutte le pagine in cui esso compare (copia e incolla). Ti posto un frammento di codice della tua home page:


speedy63
Inviato: Saturday, November 19, 2011 8:38:54 AM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,161
lui49 scusami per quella frase ch ho scritto in quel momento sono andato nel pallone, adesso ho messo la tua pagina index.html e lo chiamata home.htm o usato il blocco note di windows, ho incollato la tua pagina lo modificata inserendo il contenuto che porta alle pagine ho tolto i br., ho salvato prima la pagina home.txt e poi salvando la stessa con l'estensione htm, facendo in questo modo vedo la pagina del caso OK come il menù riprodotto da te, però in IE si vede il menù un pò scarno come se in IE mancassero gli attributi che ha FF

home IE

home FF

lui49
Inviato: Saturday, November 19, 2011 1:14:33 PM
Rank: AiutAmico

Iscritto dal : 5/4/2003
Posts: 2,472
manca nel codice la prima riga (la più importante):

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">


Utenti presenti in questo topic
Guest


Salta al Forum
Aggiunta nuovi Topic disabilitata in questo forum.
Risposte disabilitate in questo forum.
Eliminazione tuoi Post disabilitata in questo forum.
Modifica dei tuoi post disabilitata in questo forum.
Creazione Sondaggi disabilitata in questo forum.
Voto ai sondaggi disabilitato in questo forum.

Main Forum RSS : RSS

Aiutamici Theme
Powered by Yet Another Forum.net versione 1.9.1.8 (NET v2.0) - 3/29/2008
Copyright © 2003-2008 Yet Another Forum.net. All rights reserved.