Aiutamici Forum
Benvenuto Ospite Cerca | Topic Attivi | Utenti | | Log In | Registra

Inizio con Front Page Express - Collegamenti ipertestuali a file Opzioni
a.roselli
Inviato: Saturday, September 18, 2010 6:31:10 PM

Rank: Admin

Iscritto dal : 10/4/2000
Posts: 18,985
I collegamenti sono identici per tutti i tipi di file, cosi come colleghi una pagina htm devi procedere per il documento.doc, immagine.jpg, ecc. sarà poi il windows a stabilire cosa fare con il file collegato, se nel computer è presente un programma associato ai file DOC lo apre direttamente con quel programma altrimenti compare la finestra per farlo scaricare

se vuoi far solo scaricare i file DOC devi comprimerli in ZIP

probabilmente c'è un errore di percorso, inserisci l'indirizzo della pagina dove si trova il fiel DOC che vediamo dove sta il problema.



alfonso_aiutamici@hotmail.it

speedy63
Inviato: Saturday, September 18, 2010 9:44:33 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
ciao alfonso ciò che vorrei fare è solamente far aprire all'utente il file .doc semplicemente per visionarlo
il percorso è questo:la cartella Web quella con il mappamondo --- Documenti1 e il file .doc questo è il percorso nel mio pc.
Il collegamento html che porta al file è il seguente:

<a href="Documenti1/Come%20formattare%20Windows%20XP.doc">
grazie di aver risposto!!!
a.roselli
Inviato: Saturday, September 18, 2010 11:36:20 PM

Rank: Admin

Iscritto dal : 10/4/2000
Posts: 18,985
Se il link è quello dovrebbe essere corretto, caomai sostituisci gli spazi nel nome del file con dei trattini

<a href="Documenti1/Come_formattare_Windows_XP.doc">



alfonso_aiutamici@hotmail.it

speedy63
Inviato: Sunday, September 19, 2010 5:42:55 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
alfonso la riga completa è la seguente:

<option value="a href="Documenti1/Come_formattare_Windows_XP.doc">come formattare xp </a>

in questo modo il codice è corretto?

mentre se clicco sul collegamento ipertestuale quello con il testo mi si apre perfettamente il link mentre in quello sopra no
quello con il testo è il seguente:

<a href="Documenti1/Come_formattare_Windows_XP.doc">Come formattare xp </a>

come si spiega che il 1° non funziona e il 2° funziona ?

il 1° collegamento è inserito nell'elenco a discesa mentre il 2° no, io desiderei mettere in funzione quello dell'elenco a discesa e togliere il collegamento ipertestuale quello con il testo
a.roselli
Inviato: Sunday, September 19, 2010 5:52:58 PM

Rank: Admin

Iscritto dal : 10/4/2000
Posts: 18,985
Quindi è un errore del menu a discesa, cancellalo e inseriscilo di nuovo, gli altri menu a discesa funzionano?



alfonso_aiutamici@hotmail.it

speedy63
Inviato: Sunday, September 19, 2010 7:47:06 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
Questi problemi con i menù a discesa e relativi collegamenti ipertestuali c'è li ho nella pagina "Index" che sono dei collegamenti a link esterni della voce relativa che io clicco, e nella pagina "Faq" che sono dei collegamenti ipertestuali a file .doc, entrambi non funzionano.

il 1° menù a discesa l'ho preso da un sito il 2° invece l'ho generato direttamente all'interno di front Page che c'è la funzione dedicata alla creazione del menu a discesa
Cosa intendi per cancellarlo, togliere il codice che crea il menù a discesa oppure togliere il contenuto riferente?
Cosa mi consigli di usare il metodo che ho usato nel 2° menù a discesa che si trova nella pagina faq per ricreare con lo stesso metodo il 1° menù a discesa?
spero che ti sia chiaro!!!
a.roselli
Inviato: Sunday, September 19, 2010 8:22:01 PM

Rank: Admin

Iscritto dal : 10/4/2000
Posts: 18,985
Dovrei vedere il sito in funzione per trovare il problema, è anche possibile che quel menu apra solo pagine HTML, gli altri link a pagine HTML funzionano?


alfonso_aiutamici@hotmail.it

speedy63
Inviato: Monday, September 20, 2010 6:48:51 AM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
ciao il sito è : http://digilander.libero.it/skorpio19 , i collegamenti ipertestuali funzionano solo quelli in versione testo ma quelli inseriti all'interno dei due elenchi a discesa non funzionano
a.roselli
Inviato: Monday, September 20, 2010 7:38:44 AM

Rank: Admin

Iscritto dal : 10/4/2000
Posts: 18,985
speedy63, a me non funziona nessuno delle voci presente nel menu a discesa. IE mi segnala che devo installare il plugin di Media Player. Firefox quello di QuickTime ma non lo trova, Opera non segnala nulla, ma con nessuno dei tre è possibile visitare i programmi inclusi nel menu, conviene che abbandoni il menu e inserisci i link normalmente.


alfonso_aiutamici@hotmail.it

speedy63
Inviato: Monday, September 20, 2010 4:09:49 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
infatti Al nel menù a discesa non funziona nessuno quelli che funzionano sono solo quelli versione testo, quei collegamenti ipertestuali a base di testo li vorrei cambiare perchè occupano spazio e poi esteticamente stanno male, mi potresti suggerire qualche altro metodo che sia esteticamente adatto per il sito? in firefox il quick time io lo utilizzo per visualizzare la scritta skorpio19 che si muove nient'altro
speedy63
Inviato: Monday, September 20, 2010 5:42:26 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
alfonso ti metterò al più presto in linea la pagina index con il menù a tendina che apre i link a destinazione, però che li apre nella stessa pagina, ci si potrebbe aggiungere qualcosa magari accanto ai link un codice che gli permette di aprire il link in una nuova finestra?
vedi se stavolta ci riusciamo!!!
l'esempio l'ho preso da Generatore guidato alla creazione di menu a tendina
http://www.gratislandia.net/menutendina.htm
a.roselli
Inviato: Monday, September 20, 2010 6:12:35 PM

Rank: Admin

Iscritto dal : 10/4/2000
Posts: 18,985
Speedy perché non rivediamo tutto il progetto, il sito cosi come è ora fa quasi pena, tutte quelle icone grandi senza collegamento che ci stanno a fare?

Potresti utilizzare la pagina con Frame in alto dove inserire il menu, anche a discesa se vuoi, se inserisci il menu in ogni pagina e poi lo vuoi cambiare lo devi cambiare a tutte le pagine

fare qualcosa di più carino e moderno, se ci dobbiamo perdere tempo facciamo un bel lavoro rifacendo tutto, sempre secondo i tuoi gusti, ma con qualche consiglio mio.


alfonso_aiutamici@hotmail.it

speedy63
Inviato: Tuesday, September 21, 2010 8:17:10 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
ciao A. sarebbe un massacro, ho trovato, trovo tantissima fatica a crearlo così, per le immagini alcune hanno il collegamento per il commento altri portano ai link
ecofive
Inviato: Tuesday, September 21, 2010 8:38:43 PM

Rank: AiutAmico

Iscritto dal : 6/20/2008
Posts: 7,111
Speedy, sia Peron sia io ti abbiamo già postato il codice per il menu a discesa. E' questo (funziona perfettamente):

<form name="miomenu">
<select name="menu"
style="font-family: Arial; font-size: 15px; font-weight: bold; color: #000000;">
<option value="http://www.aiutamici.com/software?ID=10728">Avast!</option>
<option value="http://www.html.it">secondo link</option>
<option value="a.doc">terzo link</option>
<option value="pagina1.html">quarto link</option>
</select>
<input
onclick="top.location=document.miomenu.menu.options[document.miomenu.menu.selectedIndex].value;"
value="VAI" type="button"></form>

Metti questo codice nella pagina del sito, nel punto che vuoi.

Questo: <option value="a.doc">terzo link</option> ti apre un documento;
quest'altro: una pagina web <option value="pagina1.html">quarto link</option>.

Modifica solo i link e le parole calde dei link (es: quarto link ): se aggiungerai codice di tua fantasia, non funzionerà più nulla.

Dal lago Titicaca:



Ciao.
ecofive
Inviato: Tuesday, September 21, 2010 8:50:21 PM

Rank: AiutAmico

Iscritto dal : 6/20/2008
Posts: 7,111
Inviato per errore.
speedy63
Inviato: Wednesday, September 22, 2010 1:13:26 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
x rosselli chiarimento

codice script è esatto scritto in questa maniera? l'ho inserito all'interno del tag Body

<script language="JavaScript">

var theTarget = "_blank";

function goThere(){

var linkList=form.selectThis.selectedIndex
if(!linkList==""){window.open(form.selectThis.options[linkList].value,theTarget);}}
</script>

quest'altro sotto il tag <script>

<form name="miomenu">
<select name="menu" size="1" onChange="goThere(this.form);">

style="font-family: Arial; font-size: 15px; font-weight: bold; color: #000000;">
<option selected value="">Seleziona quello che ti serve
<option value="http://www.aiutamici.com/software?ID=10728">avast
<option value="http://www.ilsoftware.it/querydl.asp?id=745">avast cleaner

è tutto ok se è questo da me mi appare la finestra errore nello script
faccio una prova ad aprirlo con IE vediamo se mi dà lo stesso errore

questo è quello che mi risulta nella mia pagina index
a.roselli
Inviato: Wednesday, September 22, 2010 1:43:34 PM

Rank: Admin

Iscritto dal : 10/4/2000
Posts: 18,985
Non mi intento di programmazione in java, se mi dai il link dell'originale posso vedere l'errore che hai commesso

ma quello di ecofive non ti piace?


alfonso_aiutamici@hotmail.it

ecofive
Inviato: Wednesday, September 22, 2010 2:10:47 PM

Rank: AiutAmico

Iscritto dal : 6/20/2008
Posts: 7,111
Evidentemente il mio codice non gli piace ...
speedy63
Inviato: Wednesday, September 22, 2010 3:45:47 PM

Rank: AiutAmico

Iscritto dal : 3/2/2010
Posts: 1,195
eco il tuo codice l'ho rimesso ma non succede niente
ecofive
Inviato: Wednesday, September 22, 2010 5:06:10 PM

Rank: AiutAmico

Iscritto dal : 6/20/2008
Posts: 7,111
Il tuo codice è pieno di schifezze inserite precedentemente.
Questo:
<script language="JavaScript">
var theTarget = "_blank";
function goThere(){
var linkList=form.selectThis.selectedIndex
if(!linkList==""){window.open(form.selectThis.options[linkList].value,theTarget);}}
</script>

non c'entra nulla; io cancellerei.
Non ti sei poi accorto che ogni riga che comincia con <option> deve finire con </option> ? nel tuo script non c'è alcun </option>.
Aggiungi allora </option> alla fine di ogni riga.
Cancella questo codice:
<input
onclick="top.location=document.miomenu.menu.options[document.miomenu.menu.selectedIndex].value;"
value="VAI" type="button">
</select>
</form> (</select> non va scritto lì).


Sotto questa riga (che va modificata con ciò che ho aggiunto in rossso), l'ultima del tuo elenco
<option value="http://download.html.it/software/vedi/2579/wink/">Wink </option>
incolla questo codice:
</select>
<input
onclick="top.location=document.miomenu.menu.options[document.miomenu.menu.selectedIndex].value;"
value="VAI" type="button"></form>

Dopo aver apportato le modifiche, controlla che Front non ti abbia modificato lui i codici!!



Saluti dal lago Titicaca.




Utenti presenti in questo topic
Guest


Salta al Forum
Aggiunta nuovi Topic disabilitata in questo forum.
Risposte disabilitate in questo forum.
Eliminazione tuoi Post disabilitata in questo forum.
Modifica dei tuoi post disabilitata in questo forum.
Creazione Sondaggi disabilitata in questo forum.
Voto ai sondaggi disabilitato in questo forum.

Main Forum RSS : RSS

Aiutamici Theme
Powered by Yet Another Forum.net versione 1.9.1.8 (NET v2.0) - 3/29/2008
Copyright © 2003-2008 Yet Another Forum.net. All rights reserved.