Aiutamici Forum
Benvenuto Ospite Cerca | Topic Attivi | Utenti | | Log In | Registra

HD esterno non funziona. (e non ho risolto nulla) Opzioni
ciocca956
Inviato: Thursday, October 04, 2012 9:40:55 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
Salve.
Stavolta sono io ad avere problemi con un HD esterno (Seagate 7200.11 500GB).
Devo premettere che di questo HD ho una copia e che pertanto se non si riesce a rimetterlo a posto oppure si rivelasse guasto pazienza.
Nell'HD in questione vi sono due partizioni: la prima contiene dati e la seconda immagini di sistema dei vari PC che ho (anche di queste ho un'altra copia).
Succede questo: da due giorni il disco non viene rilevato dal PC all'avvio ma solo se acceso quando il Pc è già avviato. Si accende il led; si sente il suono di XP quando rileva una periferica nuova; appare sullo schermo la finestra di "Autoplay"; in risorse del computer appaiono le due icone del disco anche se non sempre entrambe (a volte una oppure l'altra) e, in Proprietà, i dischi appaiono qualche volta vuoti



e qualche volta con lo spazio occupato.



Il più delle volte però il contenuto delle cartelle non viene letto e quindi risultano vuote



e sulla barra di notifica appare questo errore



dopo di che il disco si spegne o più precisamente si spegne il led di segnalazione ma continua a girare. Si ferma quando si toglie alimentazione.
Inoltre in Gestione periferiche il disco esterno appare senza segnalini gialli e il driver non viene aggiornato perchè è "impossibile trovare un software migliore di quello correntemente installato".

Le prove che ho eseguito finora (senza esito positivo) sono:

Collegamento ad un altro PC; apertura del disco con UBUNTU ( in questo caso le cartelle non risultano mai vuote ma quando si tenta di aprire qualche file lo schermo si scurisce ed il disco dopo un po' scompare dalla cartella Computer).

In base a quanto descritto mi riesce difficile trarre una conclusione su che tipo di problema abbia questo HD.

Devo aggiungere per completezza, che da qualche settimana a volte era più rumoroso del consueto (ed è per questo che mi sono fatto una copia) ma non ha mai dato segnali di malfunzionamento. Quanto ho descritto è successo in maniera repentina.

Resto in attesa di consigli sul da farsi.
Grazie e scusate la lungaggine.
Alberto.




Sponsor
Inviato: Thursday, October 04, 2012 9:40:55 PM

 
fax71ita
Inviato: Thursday, October 04, 2012 11:24:45 PM

Rank: AiutAmico

Iscritto dal : 4/23/2010
Posts: 3,130
ciao ciocca dal computer con xp fai ancora queste prove giusto per averle provate davvero tutte....

1)cambia cavetto del hard disk o vedi che non sia danneggiato
2) cambia alimentatore del hard disk(per quelli da tavolo che usano la 220 V).questo e' stato il problema per quello di mio cognato... siamo diventati scemi... poi era l'alimentatore.....
3)cambia porta USB e riavvia
4)prova ad impostare un chkdsk da windows: Start-esegui-cmd -invio chkdsk "x": /f /x dove la "x" e' la lettera del tuo hard disk quando windows lo vede....
5 Jettalo nella monnezza.....Drool Drool Drool Whistle Silenced



ciocca956
Inviato: Thursday, October 04, 2012 11:44:59 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
fax71ita ha scritto:
ciao ciocca dal computer con xp fai ancora queste prove giusto per averle provate davvero tutte....

1)cambia cavetto del hard disk o vedi che non sia danneggiato
2) cambia alimentatore del hard disk(per quelli da tavolo che usano la 220 V).questo e' stato il problema per quello di mio cognato... siamo diventati scemi... poi era l'alimentatore.....
3)cambia porta USB e riavvia
4)prova ad impostare un chkdsk da windows: Start-esegui-cmd -invio chkdsk "x": /f /x dove la "x" e' la lettera del tuo hard disk quando windows lo vede....
5 Jettalo nella monnezza.....Drool Drool Drool Whistle Silenced



Ciao Fax
Grazie per la risposta:
Già eseguiti i cambi di cavetto, porta e alimentatore; ho cambiato anche il box ma tutto senza risultato.
Ora ho eseguito due tentativi di scandisk:
il primo si è fermato allo zero della fase due; il secondo ha dato per due volte: "impossibile aprire il volume per accesso diretto"

Opzione 5: da considerare dopo formattazione.

Alberto.
miticoalex
Inviato: Friday, October 05, 2012 1:11:16 AM

Rank: AiutAmico

Iscritto dal : 10/19/2010
Posts: 14,544
Ciao ciocca :-)

Se hai già una copia del volume, a questo punto poteresti provare a formattarlo. Oppure, se L'HD non presenta problemi

seri, si potrebbe volendo, tentare una passata con testdisk.





ciocca956
Inviato: Friday, October 05, 2012 12:33:03 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
miticoalex ha scritto:
Ciao ciocca :-)

... tentare una passata con testdisk.



Ciao Alex.
Non riesco a fare quanto mi richiedi. La guida tradotta dall'inglese non è molto comprensibile.
Stasera ti posto dove incontro difficoltà.
Alberto.
wolfestein
Inviato: Friday, October 05, 2012 6:24:27 PM

Rank: AiutAmico

Iscritto dal : 2/15/2009
Posts: 12,467
miticoalex ha scritto:
Ciao ciocca :-)Se hai già una copia del volume, a questo punto poteresti provare a formattarlo.

Meglio se a basso livello.







ciocca956
Inviato: Friday, October 05, 2012 6:55:29 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
Ciao Alex.
per eseguire Test disk ho usato questa versione



e anche la 6.14 ma entrambe mi danno questo risultato.

.

Non conoscendo il programma non so come procedere.


@Wolfestein.
Non so cosa significa ne' come si fa a formattare un disco "a basso livello".
Ciao Alberto.


miticoalex
Inviato: Friday, October 05, 2012 7:58:58 PM

Rank: AiutAmico

Iscritto dal : 10/19/2010
Posts: 14,544
ciocca956 ha scritto:
Ciao Alex.
per eseguire Test disk ho usato questa versione



e anche la 6.14 ma entrambe mi danno questo risultato.

.

Non conoscendo il programma non so come procedere.



Ciao, Alberto. In pratica, sia testdisk, che photorec, vanno lanciati direttamente dalla cartella WIN presente nella cartella che hai estratto. Almeno, nella versione 6.11. 3 che possiedo è così.

Alberto, leggo dalla schermata win live cd; non avrai scaricato la versione live cd?

Ciao


ciocca956
Inviato: Friday, October 05, 2012 8:13:45 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
miticoalex ha scritto:


Alberto, leggo dalla schermata win live cd; non avrai scaricato la versione live cd?

Ciao


Ho scaricato le due versioni 6.13 e 6.14 perche avevo inteso che la prima era Live CD e la seconda eseguibile. In ogni caso mi davano lo stesso risultato.

Ora sono in Live CD di Parted Magic che ho scoperto contenere Testdisk6.13.

L'ho avviato, penso correttamente, e il primo test sull'HD difettoso da il seguente
messaggio:

Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63
Current partition structure:
Partition Start End Size in sectors

Warning: Incorrect number of heads/cylinder 240 (NTFS) != 255 (HD)
1 * HPFS - NTFS 0 1 1 51020 254 63 819652302 [HD est.500]
Warning: Incorrect number of heads/cylinder 240 (NTFS) != 255 (HD)
2 P HPFS - NTFS 51021 0 4 60800 254 63 157115697 [COPIE DI SISTEM
A 2]

Che dici?
Ciao.
miticoalex
Inviato: Saturday, October 06, 2012 11:46:29 AM

Rank: AiutAmico

Iscritto dal : 10/19/2010
Posts: 14,544
ciocca956 ha scritto:
L'ho avviato, penso correttamente, e il primo test sull'HD difettoso da il seguente
messaggio:

Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63

Current partition structure:
Partition Start End Size in sectors (dati correnti)

Warning: Incorrect number of heads/cylinder 240 (NTFS) != 255 (HD)
1 * HPFS - NTFS 0 1 1 51020 254 63 819652302 [HD est.500] (dovresti modificare questo valore, portandolo a 240)
Warning: Incorrect number of heads/cylinder 240 (NTFS) != 255 (HD)

2 P HPFS - NTFS 51021 0 4 60800 254 63 157115697 [COPIE DI SISTEM
A 2]

Che dici?
Ciao.


Ciao, Alberto. In pratica devi modificare la geometria del disco, dallo stesso testdisk, segue:

















Cioè, devi solo modificare il valore degli HEADS; come vien evidenziato dal programma, il valore da mettere può variare tra 240, 255, e lo stesso 16. Tu metti 240, l'attuale è 255. Una Volta immesso il valore, pigia enter, e poi OK.

Riprova a collegarlo ed eventualmente rifai il test.

Ciao




ciocca956
Inviato: Saturday, October 06, 2012 9:14:55 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
Ciao Alex
ho fatto quanto suggerisci ma senza risultato.
Ho provato più volte a modificare la geometria del disco e sempre dato OK ma al riavvio l'HD presenta sempre gli stessi problemi e rilanciando Testdisk mi ritrovo sempre la stessa segnalazione di errore come se la modifica apportata al numero di Heads non venisse salvato.

Disk /dev/sdb - 500 GB / 465 GiB - CHS 60801 255 63
Current partition structure:
Partition Start End Size in sectors

Warning: Incorrect number of heads/cylinder 240 (NTFS) != 255 (HD)
1 * HPFS - NTFS 0 1 1 51020 254 63 819652302 [HD est.500]
Warning: Incorrect number of heads/cylinder 240 (NTFS) != 255 (HD)
2 P HPFS - NTFS 51021 0 4 60800 254 63 157115697 [COPIE DI SISTEM
A 2]

Come vedi è ancora uguale a prima. Forse sbaglio qualcosa.

Comunque per curiosità ho provato ad analizzare il disco principale con i S.O. XP e Ubuntu e stranamente mi indica lo stesso errore.


Disk /dev/sda - 500 GB / 465 GiB - CHS 60801 255 63
Current partition structure:
Partition Start End Size in sectors

>Warning: Incorrect number of heads/cylinder 41 (NTFS) != 255 (HD)
Warning: Incorrect number of sectors per track 20 (NTFS) != 63 (HD)
1 * HPFS - NTFS 0 0 21 13427 31 32 215706720

Bad relative sector.
3 E extended LBA 13427 45 57 60801 70 45 761064874
Warning: Incorrect number of sectors per track 20 (NTFS) != 63 (HD)
5 L HPFS - NTFS 27223 47 9 42580 123 31 246715016 [DATI????]
X extended 42580 123 32 60801 70 45 292717040
Warning: Incorrect number of heads/cylinder 41 (NTFS) != 255 (HD)
Warning: Incorrect number of sectors per track 20 (NTFS) != 63 (HD)
6 L HPFS - NTFS 42580 123 56 60801 70 45 292717016 [COPIA HD EST]
X extended 13427 45 58 25949 125 32 201170945
7 L Linux 13427 45 59 25949 125 32 201170944




Forse questo errore non è determinante perchè il disco funziona regolarmente e e entrambi i S.O. girano.


Una ultima curiosità. Sai spiegarmi perchè la prima partizione del disco difettoso vieno rilevata come botabile? Non dovrebbe essere primaria?
Ho provato a modificare la caratteristica ma anche questa non la prende.

Anche G.Parted vede il disco e le partizioni. La prima segnala un errore con un triangolino arancione.
L'errore è questo (io non lo comprendo): "This software has detected that the disk has at least 1 bad sector".

Alberto.
wolfestein
Inviato: Sunday, October 07, 2012 12:00:27 AM

Rank: AiutAmico

Iscritto dal : 2/15/2009
Posts: 12,467
This software has detected that the disk has at least 1 bad sector = Questo software ha rilevato che almeno un settore del disco è danneggiato.
Se ci riesci salva i dati e formattalo a basso livello sperando che questa operazione riesca a recuperare l'hd anche se è poco probabile,comunque tentar non nuoce.

ciocca956
Inviato: Sunday, October 07, 2012 2:21:49 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
wolfestein ha scritto:
This software has detected that the disk has at least 1 bad sector = Questo software ha rilevato che almeno un settore del disco è danneggiato.
Se ci riesci salva i dati e formattalo a basso livello sperando che questa operazione riesca a recuperare l'hd anche se è poco probabile,comunque tentar non nuoce.


Ciao Wolf.
L'indicazione è chiara e comunque , come detto sopra, delle due partizioni di questo HD già da tempo ho la copia. E perdona la mia ignoranza ma non so cosa intendi per formattazione a "basso livello". Non avendo mai formattato un HD no so nemmeno con esattezza come procedere. Mi dai suggerimenti in merito?

Grazie Alberto.
wolfestein
Inviato: Sunday, October 07, 2012 3:44:53 PM

Rank: AiutAmico

Iscritto dal : 2/15/2009
Posts: 12,467
Io uso questo programma,semplice da usare,lo installi selezioni l'hd da formattare e dai il via.
Prima di riusare il disco ricrea(lo suggerisce anche il programma stesso) la partizione con un programma come Esaeus Partition Master.


ciocca956
Inviato: Sunday, October 07, 2012 8:15:16 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
wolfestein ha scritto:
....semplice da usare,lo installi selezioni l'hd da formattare e dai il via.
....

Ciao Wolfy.
E' facile a dirsi ma non a farsi.
Quando dopo l'avvio l'HD appare in Risorse del Computer non mi lascia aprire nè il programma che suggerisci, nè il tool di distruzione dei file di Acronis nè la gestione disco di Windows.
Anzi se non spengo il disco il PC mi rimane bloccato.
Dovrò escogitare qualche strada per aggirare il problema.

Vedremo.
Per intanto grazie. Alberto.
miticoalex
Inviato: Monday, October 08, 2012 1:17:34 AM

Rank: AiutAmico

Iscritto dal : 10/19/2010
Posts: 14,544
Ciao, Alberto. Forse ti conviene formattarlo a basso livello con uno dei tool presenti in ultimate boot CD.



wolfestein
Inviato: Monday, October 08, 2012 6:49:21 PM

Rank: AiutAmico

Iscritto dal : 2/15/2009
Posts: 12,467
ciocca956 ha scritto:
Quando dopo l'avvio l'HD appare in Risorse del Computer non mi lascia aprire nè il programma che suggerisci, nè il tool di distruzione dei file di Acronis nè la gestione disco di Windows.

Tutto questo è veramente strano,ho usato di recente HD Low Level Format per formattare l'hd del mio portatile senza problemi.
Prova a usare questa procedura:
Collega l'hd al computer non aprire nessuna applicazione o finestra e lancia il programma,questi rileverà tutti i dischi presenti o collegati al computer,seleziona l'hd esterno e procedi con la formattazione.

ciocca956
Inviato: Monday, October 08, 2012 9:56:01 PM

Rank: AiutAmico

Iscritto dal : 1/5/2012
Posts: 3,106
wolfestein ha scritto:

Prova a usare questa procedura:
Collega l'hd al computer non aprire nessuna applicazione o finestra e lancia il programma,questi rileverà tutti i dischi presenti o collegati al computer,seleziona l'hd esterno e procedi con la formattazione.


Ciao Wolfy.

Stavolta il programma è partito.

Ho seguito le tue indicazioni ma non sono certo di non aver messo in atto lo stesso accorgimento anche in precedenza.
Ieri sera ho tentato di eseguire la formattazione installando un S.O. Il tentativo di installare XP è subito abortito mentre l'installazione di UBUNU (seconda opzione: "installa occupando tutto il disco") si è bloccata in fase di formattazione che non si è mai conclusa (dopo circa mezzora ho riavviato il PC).
Non so se ciò può influito su quanto succede stasera. Spero vada a buon fine.
Alberto.

@MiticoAlex.
E' appena terminato il download di UBCD. Ora masterizzo il CD. Se servisse sarà pronto. Mi sembra un Utility molto interessante dalle guide che ho letto.
Ciao.
wolfestein
Inviato: Monday, October 08, 2012 10:01:14 PM

Rank: AiutAmico

Iscritto dal : 2/15/2009
Posts: 12,467
Ciao Alberto!
Se nemmeno la formattazione a basso livello funzionerà l'hd si può considerare perduto.


Utenti presenti in questo topic
Guest


Salta al Forum
Aggiunta nuovi Topic disabilitata in questo forum.
Risposte disabilitate in questo forum.
Eliminazione tuoi Post disabilitata in questo forum.
Modifica dei tuoi post disabilitata in questo forum.
Creazione Sondaggi disabilitata in questo forum.
Voto ai sondaggi disabilitato in questo forum.

Main Forum RSS : RSS

Aiutamici Theme
Powered by Yet Another Forum.net versione 1.9.1.8 (NET v2.0) - 3/29/2008
Copyright © 2003-2008 Yet Another Forum.net. All rights reserved.